Prestashop : versions PHP

Puisque la question m’a été posée plusieurs fois, voilà quelques infos sur Prestashop versions 1.4 et 1.5 et PHP.

Si vous recevez un courrier de votre hebergeur vous signalant que votre site utilise une version obsolète de PHP (5.3 ou anterieures) en vous conseillant de migrer vers une version plus récente,
idéalement PHP 5.5 ou 5.6, il est préférable de le faire.

gophp5-283x100

Selon l’hebergeur, la manip est plus ou moins facile.

– Chez 1and1, c’est une case à cocher pour choisir la version de PHP.

– Chez OVH, c’est un peu plus « artisanal » : il faut créer un fichier .ovhconfig et le transferer par ftp à la racine de votre hebergement pour spécifier la version (aide OVH).

Pas de problème de compatibilité entre Prestashop 1.4 et 1.5 et PHP5. Vous pouvez migrer vers cette version récente de PHP sans risque.

Seule la fonction « rechercher » risque d’être impactée. Testez la après avoir fait la migration. S’il n’y a « aucun résultat » lors des recherches sur votre boutique, il faudra modifier le fichier search.php dans boutique/classes.

Vous trouverez les indications dans cet échange (lien), sur le forum Prestashop.

Prestashop : versions PHP